FTTC Fast Path (Interleaving) removal with Plusnet

A quick and free boost for my broadband connection this week. I’d been monitoring my DSL service and was noticing some errors on the downstream and with some quick research Interleaving was a common cause of this. Interleaving in short splits your packets down and reassembles at the far end, it’s great for stability but does increase latency. It’s not great if you use VOIP and if you’re a gamer it can increase that all important response time which you need as low as possible.

A quick webchat with Plusnet support and I’d asked for my service to be put on “fast track” or in other words, having interleaving removed. A 24 hour wait and to my surprise my connection has improved!

Before;

After;

 

The only issue with this is if Interleaving was helping the connection there is a possibility it will wobble and DLM will re-apply it but the service in general is very stable so I am hopeful that the change will last.

MikroTik Fast Track Learning Experience

Free performance enhancement? Must be a catch….

I’ve recently had to investigate making some lower powered MikroTik devices route at decent speeds, there is a much longer story which I won’t be going in to but in short I had a task of making a CRS112 (low powered 400Mhz single core CPU) able to route 100Mb services.

A little background is the CRS112 is primarily a switch, using hardware offload you can easily switch at line rate (Gigabit) however they don’t really do too well in routing or anything CPU oriented. For example viewing Winbox uses 20% CPU resources as does running FTP, Telnet and WWW services!

For basic NAT masquerade and a simple 12 line firewall rule my initial testing was only yielding speed test results in the 30-40Mb region. The first 2 lines of my firewall were as follows to try and be as efficient as I could be;

/ip firewall filter

add action=accept chain=forward comment="ACCEPT ESTABLISHED & RELATED" connection-state=established,related in-interface=pppoe_client1

add action=accept chain=input comment="ACCEPT ESTABLISHED & RELATED" connection-state=established,related in-interface=pppoe_client1

The goal was to route at least 50Mb through the CRS so I picked up something I left alone a long time ago as then there was no need to use CPU limited products and the cons outweighed the gains.

Fasttrack is a powerful little tool you can use to vastly improve throughputs on CPU limited devices, the plus sides of it are that my CRS112 that was only previously capable of routing 30Mb was now being limited by my PPP account at 150Mb and it still had gas in the tank! The device suddenly becomes a much more viable router however the draw back to this is that fast track effectively allows the packet “through the gates” and then takes no further part in it’s journey. Connection tracking is disabled meaning any further mangling of packets and queues simply do not know about the packets we have just expedited.

In most situations fasttrack is probably going to break more things than you’d like whilst trying to squeeze the last bit out of your router however on heavily CPU limited tasks where you only need a basic router it will certainly help.

The final firewall configuration only needed 2 lines adding (yes I tried without the accept rules and it won’t work);

/ip firewall filter

add action=fasttrack-connection chain=forward comment="ACCEPT ESTABLISHED & RELATED" connection-state=established,related in-interface=pppoe_client1

add action=fasttrack-connection chain=input comment="ACCEPT ESTABLISHED & RELATED" connection-state=established,related in-interface=pppoe_client1

add action=accept chain=forward comment="ACCEPT ESTABLISHED & RELATED" connection-state=established,related in-interface=pppoe_client1

add action=accept chain=input comment="ACCEPT ESTABLISHED & RELATED" connection-state=established,related in-interface=pppoe_client1

So to summarise, fasttrack is the devil unless you have a low powered device. Connection tracking is probably more valuable than making your under specced kit last an extra couple of weeks but a very good learning experience.

MikroTik WAP60G Wireless Wire – The Best You’ll Never Use!

wirelesswire

OK so maybe I was a little harsh in the title, but to be honest. It’s quite true for the UK right now.

MikroTiks wireless wire truly is a groundbreaking product, Gigabit full duplex link over wireless at a total retail cost of less than £200 but if something sounds to good to be true, it usually is. The form factor of these units following the WAP build is great, small, versatile and outdoor grade, they feel so well made with a good weight to them. The box comes presented well and they have a nearly premium feel when you are opening the package (something which normally eludes even the expensive MikroTik products). Out of the box they follow MikroTiks normal IP convention of being on 192.168.88.0/24 space and are addressed and fully secured from the off, you can literally connect them and start passing traffic over them. So I did.

Performance was just as good as expected, with the units in very close proximity (probably a little too close) they were quite capable of maintaining a +800Mb speed test although that was using the built in bandwidth tester which is quite notorious for not being as efficient as it could be. Single duplex tests were slightly better as expected and when the connection was limited to “only” 500Mb either direction latency was measured at <1ms. At full tilt the latency did get a little wobbly but again I’m more along the lines of thinking this was the CPU’s in the devices that the actual link limitations.

tik60g2

So why won’t we be using this?

Unfortunately for our country whilst the use of the 60Ghz frequencies mentioned is license exempt, there are stipulations you need to adhere to, this one falls over in that whilst MikroTik haven’t officially released the specs, it is speculated the antenna gain in them is around 13dB which falls short of OFCOMs guideline stating that you need to use a minimum of 30dB to legally use the 60Ghz spectrum outdoors (page 2 if you’re interested). For the time being this means that this amazing wireless wire product is indoor use only.

There is a company though in Poland who are currently developing some larger antenna for them http://siec.multimediahd.pl/

So whilst the Gigabit full duplex low latency low price link is something we certainly want to see more of, you won’t be seeing one mounted externally anywhere near you any time soon (well not legally anyway).

MikroTik website product link here